设为首页收藏本站每日签到

深圳网吧联盟论坛

 找回密码
 立即加入本站

QQ登录

只需一步,快速开始

搜索
查看: 11790|回复: 32

[原创]ROS3.13做无线路由实例(图文)

[复制链接]
  • TA的每日心情
    奋斗
    7 天前
  • 签到天数: 987 天

    [LV.10]以坛为家III

    发表于 2010-5-9 10:16:00 | 显示全部楼层 |阅读模式

    ROS系统要求:

    必需安装Wireless组件和dhcp组件).不安装的请解压安装包后将Wireless.npk及dhcp. npk上传到FTP上并重启。。安装成功后如下图。。

    必需安装有无线网卡,并且ROS能正常识别。。安装成功后如下面。。

    设置开始。。

    我们先给无线网卡设置一个IP。。我们以192.168.2.0/24网段为例。。设置无线网卡内网IP为:192.168.2.254。。设置完成后如下图:

    相关脚本如下:

    /ip address add address=192.168.2.254/24 interface=wlan1

    我们这里分两大步骤来设置

    一、先设置DHCP服务。

    进入winbox --- IP --- DHCP Server   点击DHCP Setup进入设置向导。。如下图:

    选择我们要设置DHCP服务的网卡。。这里我们选择无线网卡。。即wlin1。。如下图:


    点击[Next]下一步。。设置无线服务的网段。。上面我们说了以192.168.2.0/24为例。。所以我们这里设置192.168.2.0/24。。如下图:

    点击[Next]下一步。。设置无线网络内网网关。。即我们第一步设置的无线网卡IP地址。。如下图:


    点击[Next]下一步。。这里设置无线网络客户机将所获取到的IP范围。。在这里我们设置192.168.2.1-192.168.2.253。。如下图:


    点击[Next]下一步。。设置DNS。。在这里不多说。。如下图:

    点击[Next]下一步。。这里设置租期。。一般设置三天。。如下图:

    点击[Next]完成向导。。成功后如下图(红线部分为我们刚才向导添加的):

    习惯性将其更名为:WlanDHCP。如下图:

    好了。。第一个步骤的DHCP服务已经设置成功。。

    相关脚本如下:

    /ip dhcp-server add address-pool=dhcp_pool3 authoritative=after-2sec-delay bootp-support=static disabled=no interface=wlan1 lease-time=3d name=WlanDHCP

    /ip dhcp-server network add address=192.168.2.0/24 comment="" dns-server=202.96.134.133 gateway=192.168.2.254

    /ip pool add name=dhcp_pool3 ranges=192.168.2.1-192.168.2.253


    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即加入本站

    x
  • TA的每日心情
    奋斗
    7 天前
  • 签到天数: 987 天

    [LV.10]以坛为家III

     楼主| 发表于 2010-5-9 10:49:00 | 显示全部楼层

    我们测试一下。。由于我这里没有现成的无线PC。。用自己的N95试连了一下。。成功。

     

    如下图。。

     


    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即加入本站

    x
  • TA的每日心情

    2013-4-10 02:12
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2010-5-9 10:58:00 | 显示全部楼层

    LZ发迟了一点,我前几天很需要这个,搞得我..........55555555555555555

  • TA的每日心情
    奋斗
    7 天前
  • 签到天数: 987 天

    [LV.10]以坛为家III

     楼主| 发表于 2010-5-9 10:17:00 | 显示全部楼层

    二、设置无线网卡服务。。进入winbox --- Wireless

    1。添加模版。。如下图:

    相关设置如下图:




    点击OK保存!

    相关脚本如下:

    /interface wireless security-profiles

    add authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip \
        group-key-update=5m interim-update=0s mode=static-keys-required name=\
        wlan_profile radius-eap-accounting=no radius-mac-accounting=no \
        radius-mac-authentication=no radius-mac-caching=disabled \
        radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
        static-algo-0=40bit-wep static-algo-1=none static-algo-2=none \
        static-algo-3=none static-key-0=123456 static-key-1="" static-key-2=\
        "" static-key-3="" static-sta-private-algo=none static-sta-private-key="" \
        static-transmit-key=key-0 supplicant-identity="" tls-certificate=none \
        tls-mode=no-certificates unicast-ciphers=tkip wpa-pre-shared-key="" \
        wpa2-pre-shared-key=""

    2。修改无线网卡属性。。如下图:





    点击OK。。大功告成。。。

    这步没脚本。。自己手工设置吧。。

    测试一下是否正常。。

     

    [此贴子已经被作者于2010-5-9 10:47:39编辑过]

    本帖子中包含更多资源

    您需要 登录 才可以下载或查看,没有帐号?立即加入本站

    x

    该用户从未签到

    发表于 2010-5-9 12:45:00 | 显示全部楼层
    [em60]顶一个

    该用户从未签到

    发表于 2010-5-9 12:45:00 | 显示全部楼层

    [em51]版主

     

    该用户从未签到

    发表于 2010-5-23 11:40:00 | 显示全部楼层

    绝对顶上去啦。

    该用户从未签到

    发表于 2010-5-16 09:13:00 | 显示全部楼层
    我最感兴趣的还是楼主的N95,挖哈哈。

    该用户从未签到

    发表于 2010-5-30 17:47:00 | 显示全部楼层
    谢谢楼主。又学习了!!

    该用户从未签到

    发表于 2010-6-13 14:38:00 | 显示全部楼层

    很好。。。

     

    推荐一下,用什么无线网卡好?

    该用户从未签到

    发表于 2010-6-14 18:35:00 | 显示全部楼层
    DHCP也可以不用装。搞成PPPOE拨号让无线连接上网也可以。或者设置固定IP也可以。
    [此贴子已经被作者于2010-6-14 18:35:35编辑过]

    该用户从未签到

    发表于 2010-6-16 18:47:00 | 显示全部楼层
    顶,支持。
  • TA的每日心情
    开心
    2016-3-29 08:44
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    发表于 2010-6-16 17:24:00 | 显示全部楼层
    学习了,很受用啊,感谢老大分享啊

    该用户从未签到

    发表于 2010-6-23 15:40:00 | 显示全部楼层
    这么好的帖子,不顶不行

    该用户从未签到

    发表于 2010-8-1 15:09:00 | 显示全部楼层
    这个是设置ros做无线AP的吧!!想知道怎么设置无线客户端模式

    该用户从未签到

    发表于 2010-8-29 14:38:00 | 显示全部楼层
    又学了一招!哈哈......[em60]

    该用户从未签到

    发表于 2010-10-26 16:50:00 | 显示全部楼层
    说真的,好东西,收藏了
  • TA的每日心情
    开心
    2012-9-26 20:56
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2012-1-11 19:33:46 | 显示全部楼层
    好啊。大力支持!
  • TA的每日心情
    奋斗
    2013-11-14 16:28
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2012-2-7 14:14:44 | 显示全部楼层
    想留名也这么难
  • TA的每日心情
    开心
    2012-9-26 20:56
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2012-2-15 19:20:16 | 显示全部楼层
    好啊.支持下.``
    您需要登录后才可以回帖 登录 | 立即加入本站

    本版积分规则

    QQ|小黑屋|手机版|无图版|深圳网吧联盟 ( 粤ICP备06037878号-1  

    GMT+8, 2018-10-18 17:06 , Processed in 0.129896 second(s), 33 queries .

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表